$re = '/(\w+\-).*\1/m';
$str = 'https://beta.blick.ch/news/ausland/klimawandel-klimawandel-anstieg-des-meeresspielgel-um-einen-meter-id1419139.html
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);