import re
regex = re.compile(r"<\s*span[^>]*>(.*?)<\s*\/\s*span\s*>", flags=re.MULTILINE)
test_str = ("<p nameIt=\"Title\">Title_Test</p><figure class=\"t15\"><table><thead><tr>\n"
"<th><span>Column1</span></th><th><span>Column2</span></th></tr></thead><tbody><tr><td><span>Entry1</span></td><td><span>Entry2</span></td><td><span>ready</span></td></tr></tbody></table></figure><p ex=\"ready\">!aaa; ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")