$re = '/(?<!\S)(\w+)(?:\s+\1)+(?!\S)/m';
$str = 'Paris in the the spring.
Not that that is related.
Not that that that is related.
This is $word word';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);