$re = '/(?<=_)\d+-\d+-\d+(?=(?: \d{8})?\.xlsx\b)/m';
$str = '28-3G__1-2-19 02252019.xlsx
12H-14W_1-5-19 02252019.xlsx
343X-N_11-12-18.xlsx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);