package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(.*)\]`)
var str = `<HR>\n[{"key":"value","key2":["¥"]}]\n<HR>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}