#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms){% comment %}.*{% endcomment %}"
Local $sString = "--font-heading: {{ settings.header_font_1_1.family }};" & @CRLF & _
"--font-standard: {{ settings.general_font_1_1.family }};" & @CRLF & _
"" & @CRLF & _
" --body-font-size: {{settings.body_font_size}}px;" & @CRLF & _
" --font-small: 14px;" & @CRLF & _
" --font-medium: 17px;" & @CRLF & _
" --font-bold: 300;" & @CRLF & _
" --size-h1: {{settings.heading_size_1}}px;" & @CRLF & _
" --size-h2: {{settings.heading_size_2}}px;" & @CRLF & _
" --size-h3: {{settings.heading_size_3}}px;" & @CRLF & _
" --size-h4: {{settings.heading_size_4}}px;" & @CRLF & _
" --size-h5: {{settings.heading_size_5}}px;" & @CRLF & _
" --size-h6: {{settings.heading_size_6}}px;" & @CRLF & _
" --top-font-size: {{settings.top_bar_size}}px;" & @CRLF & _
" --product-font-size: {{settings.product_title_size}}px;" & @CRLF & _
" --product-price-size: {{settings.product_price_size}}px;" & @CRLF & _
" --footer-size: {{ settings.footer_font_size }}px;" & @CRLF & _
" {% comment %} --home-title-font-size: {{settings.home_title_size}}px; {% endcomment %}" & @CRLF & _
" --product-detail-title-size: {{settings.product_detail_title_size}}px;" & @CRLF & _
"" & @CRLF & _
" --font-icon : 20px;" & @CRLF & _
" --font-small-icon: 21px;" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")