package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*(Work?|W?ork).*$`)
var str = `HelloWorld
HelloWolrd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}