re = /(?mx)
(?:\+?\(?\d{1,4}\)?\ ?\.?\-?)+/m
str = '123-456-5555
(123) 222-1234
123 555 5555
123.777.7979
+91 (123) 455-6000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end