$re = '/\[(?P<date>.*)\]\s(?<channel>.*)\.(?<severity>.*):\s(?<message>.*)\s(\[|\{)(?<context>.*)(\]|\})\s\[(?<extra>.*)\]/';
$str = '[2013-08-15 14:19:51] context.INFO: multicontext test {foo} {bat} [{"foo":"bar"},{"bat":"baz"}] []';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);