import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\D{8}(?<time>\\d[^\\s]*\\s[^\\s]*)\\s(?<severity>\\w)\\s[/|]\\s(?<source>[^\\s]*[\\:])[\\s]*(?<message>.*[/\\/n])([\\W]*[\\w]*){3}[\\W]{3}(?<logdate>[\\d]*\\-[\\d]*\\-[\\d]*)\\w(?<logtime>[\\d]*\\:[\\d]*\\:[\\d]*\\.[\\d]*)\\w\\W*$";
final String string = "{\"log\":\"2017-12-19 13:32:01.280700 I | etcdmain: etcd Version: 3.0.17\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.281026986Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.280914 I | etcdmain: Git SHA: cc198e2\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.281103421Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.280923 I | etcdmain: Go Version: go1.6.4\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.281107072Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.280928 I | etcdmain: Go OS/Arch: linux/amd64\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.281108985Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.280933 I | etcdmain: setting maximum number of CPUs to 4, total number of available CPUs is 4\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.281110867Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.281161 N | etcdmain: the server is already initialized as member before, starting as etcd member...\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.281297016Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.282067 I | etcdmain: listening for peers on http://localhost:2380\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.282350397Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.282152 I | etcdmain: listening for client requests on 127.0.0.1:2379\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.282361979Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.286927 I | etcdserver: recovered store from snapshot at index 15161518\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.29074204Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.286950 I | etcdserver: name = default\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.290753557Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.286955 I | etcdserver: data dir = /var/lib/etcd\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.290756077Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.286960 I | etcdserver: member dir = /var/lib/etcd/member\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.290758045Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.286965 I | etcdserver: heartbeat = 100ms\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.290759777Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.286968 I | etcdserver: election = 1000ms\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.290761577Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.286972 I | etcdserver: snapshot count = 10000\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.290763342Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.286983 I | etcdserver: advertise client URLs = http://127.0.0.1:2379\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.290765215Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.786992 I | etcdserver: restarting member 8e9e05c52164694d in cluster cdf818194e3a8c32 at commit index 15168960\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.787878528Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.788412 I | raft: 8e9e05c52164694d became follower at term 9\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.791064352Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.788435 I | raft: newRaft 8e9e05c52164694d [peers: [8e9e05c52164694d], term: 9, commit: 15168960, applied: 15161518, lastindex: 15168960, lastterm: 9]\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.791076857Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.788561 I | api: enabled capabilities for version 3.0\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.791079764Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.788574 I | membership: added member 8e9e05c52164694d [http://localhost:2380] to cluster cdf818194e3a8c32 from store\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.791082008Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.788582 I | membership: set the cluster version to 3.0 from store\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.791084212Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.792500 I | mvcc: restore compact to 5751429\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.794829127Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:01.797258 I | etcdserver: starting server... [version: 3.0.17, cluster version: 3.0]\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:01.797433251Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:02.588875 I | raft: 8e9e05c52164694d is starting a new election at term 9\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:02.589552499Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:02.589298 I | raft: 8e9e05c52164694d became candidate at term 10\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:02.589571444Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:02.589306 I | raft: 8e9e05c52164694d received vote from 8e9e05c52164694d at term 10\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:02.589574111Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:02.589319 I | raft: 8e9e05c52164694d became leader at term 10\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:02.589584935Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:02.589327 I | raft: raft.node: 8e9e05c52164694d elected leader 8e9e05c52164694d at term 10\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:02.58958702Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:02.590591 I | etcdserver: published {Name:default ClientURLs:[http://127.0.0.1:2379]} to cluster cdf818194e3a8c32\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:02.605236261Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:02.590605 I | etcdmain: ready to serve client requests\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:02.605250506Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:02.590922 N | etcdmain: serving insecure client requests on 127.0.0.1:2379, this is strongly discouraged!\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:02.605253194Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:13.727465 W | etcdserver: apply entries took too long [18.964348ms for 1 entries]\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:13.73174732Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:13.728444 W | etcdserver: avoid queries with large range/delete range!\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:13.731786609Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:17.119442 W | etcdserver: apply entries took too long [11.388753ms for 1 entries]\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:17.136726266Z\"}\n"
+ "{\"log\":\"2017-12-19 13:32:17.119466 W | etcdserver: avoid queries with large range/delete range!\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:32:17.13674029Z\"}\n"
+ "{\"log\":\"2017-12-19 13:33:12.813262 W | etcdserver: apply entries took too long [12.968146ms for 1 entries]\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:33:12.817703884Z\"}\n"
+ "{\"log\":\"2017-12-19 13:33:12.814159 W | etcdserver: avoid queries with large range/delete range!\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:33:12.817722819Z\"}\n"
+ "{\"log\":\"2017-12-19 13:33:53.019317 W | etcdserver: apply entries took too long [34.109947ms for 1 entries]\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:33:53.027210205Z\"}\n"
+ "{\"log\":\"2017-12-19 13:33:53.019867 W | etcdserver: avoid queries with large range/delete range!\\n\",\"stream\":\"stderr\",\"time\":\"2017-12-19T13:33:53.027233576Z\"}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}