package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(?:<br\s*\/?>)+\s*$`)
var str = `<br /> remove HTML breaks after this string <br/><br><br /><br/><br><br /><br /><br/>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}