package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\d{4}$`)
var str = `party like it's 1999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}