package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]{5}\d{4}[A-Z]`)
var str = `AAAAA0001A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}