re = /^(?!(YourCheckName)).+/m
str = 'AnyRuleThatContainsYourCheckName
AnyRuleThatContainsYourCheckNameInTheMiddle
YourCheckName
YourCheckNameRule
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end