use strict;
my $str = 'const workInProgressRegex = /<[\\w]+[^>]*>.*?(#(?:[0-9a-fA-F]{3}){1,2})<\\/[\\w]+>/gim;
const exampleString1 = `<div><span class="foo" style="background-color: #ffffff;">#222222 foo #111111 abc #000000</span></div>`;
const exampleString2 = `<div><span class="foo" style="background-color: #ffffff;">"\'#222222 foo #111111 abc #000000</span></div>`;
const result1 = exampleString1.replaceAll(workInProgressRegex, "bar");
// should be `<div><span class="foo" style="background-color: #ffffff;">bar foo bar abc bar</span></div>`
const result2 = exampleString1.replaceAll(workInProgressRegex, "bar");
// should be `<div><span class="foo" style="background-color: #ffffff;">"\'bar foo bar abc bar</span></div>`';
my $regex = qr/(#[0-9|a-f]{6})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}