using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!https:\/\/)(?<!http:\/\/)(www\.[\w-.]*?[\w-]+?(\/[\w-]*?)*?)((?=[^\w.\/-]+?)|$)+";
string input = @"<p><a href=""https://www.w3schools.com/html/""><a href=""http://www.w3schools.com/html/"">www.w3schools.com</a></p>
<p><a href=""https://www.google.com/html/""><a href=""http://www.google.com/html/"">www.google.com</a></p>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}