// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)([^\/]{2,2}|^)(www\.[\w-.]*?[\w-]+?(\/[\w-]*?)*?)(([^\w.\/-]+?)|$)+").unwrap();
let string = "<p><a href=\"https://www.w3schools.com/html/\"><a href=\"http://www.w3schools.com/html/\">www.w3schools.com</a></p>
<p><a href=\"https://www.google.com/html/\"><a href=\"http://www.google.com/html/\">www.google.com</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}