$re = '/^(?:(?:1?\d{1,4}|20[0-3]\d\d|204[0-6]\d|2047[0-8])(?:\.\d+)?|20479(?:\.0+)?)$/m';
$str = '0.0
321.321
9877.798
20419.3
20479.0
20479.01
20479.1
20480.0
30000
44444.444
11111.111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);