re = /(?<=\|)\d+(?=\|)|(?<=\+)\d+(?=\+)|(?<=\$)\d+|\d+(?=%)/
str = 'Theses are some of the fail cases that I am looking to avoid variable123 or variable_123name or _123_, where some of the acceptable cases are |123| or +123+ $123 123% ext...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end