$re = '/https:\/\/tokopedia\.link/';
$str = 'https://tokopedia.link/tCfbu2GngGb';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);