const regex = /(?P<Timestamp>\b(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)\s+\d+\s+\d+:\d+:\d+)\b\s+(?P<FW_ip_addr>\d+\.\d+\.\d+\.\d+)\s+(?P<Event_id>%\w+-\d+-\d+):\s+(?P<Event_message>Built (inbound|outbound) ICMP connection for faddr)\s+(?P<foreign_ip_addr>.*)\s+gaddr\s+(?P<global_ip_addr>.*)\s+laddr\s+(?P<local_ip_addr>.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<Timestamp>\\b(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)\\s+\\d+\\s+\\d+:\\d+:\\d+)\\b\\s+(?P<FW_ip_addr>\\d+\\.\\d+\\.\\d+\\.\\d+)\\s+(?P<Event_id>%\\w+-\\d+-\\d+):\\s+(?P<Event_message>Built (inbound|outbound) ICMP connection for faddr)\\s+(?P<foreign_ip_addr>.*)\\s+gaddr\\s+(?P<global_ip_addr>.*)\\s+laddr\\s+(?P<local_ip_addr>.*)', 'g')
const str = `Jul 25 23:57:18 210.56.128.109 %PIX-6-302020: Built outbound ICMP connection for faddr Odyssey_192.168.26.50/0 gaddr youngphoenix/35389 laddr youngphoenix/35389
Jul 25 23:57:34 210.56.128.109 %PIX-6-302020: Built inbound ICMP connection for faddr Thetis2/38748 gaddr 210.56.128.109/0 laddr 210.56.128.109/0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}