import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s*([\\0\\b\\'\\\"\\n\\r\\t\\%\\_\\\\]*\\s*(((select\\s+\\S.*\\s+from\\s+\\S+)|(insert\\s+into\\s+\\S+)|(update\\s+\\S+\\s+set\\s+\\S+)|(delete\\s+from\\s+\\S+)|(((drop)|(create)|(alter)|(backup))\\s+((table)|(index)|(function)|(PROCEDURE)|(ROUTINE)|(SCHEMA)|(TRIGGER)|(USER)|(VIEW))\\s+\\S+)|(truncate\\s+table\\s+\\S+)|(exec\\s+)|(\\/\\*)|(--)))(\\s*[\\;]\\s*)*)+)";
final String string = "exect";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}