package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^.]+(\.[gl]t)?$`)
var str = `anytext
anytext.gt
anytext.lt
anytext.xx
anytext.xx.gt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}