re = /\brahuls?[^\s\w]*(?=\s|$)/i
str = 'hello rahul! vyas and rahul? and rahul. and rahul: and rahul and rahul( and rahul) and rahul{ rahul.shiv '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end