$re = '/\{object_image(.+?)\}/m';
$str = '{object_image id="51" class="abc"} xxx {object_image id="100" attr="zzz"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);