re = /(?<date>[^ ]+$)/m
str = '||pool-2-thread-1|| INFO com.tmobile.sfdc.reports.batch.listener.OrderJobListener - ORDER_JOB: ACTIVE at START_TIME: 2018-05-07T06:04:46.087Z'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end