$re = '/^\s*(?!.{32}\s?\w)\w+(?:\s\w+)*\s*$/m';
$str = ' test test test test test test te
test test test test test test te
test test test test test test test ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);