re = /(?<=\/)(?![A-Za-z]+_[^\/]+$)[A-Za-z]+_[^\/]+/m
str = '/w_100/h_500/e_saturation:50,e_tint:red:blue/c_crop,a_100,l_text:Neucha_26_bold:Loremipsum./l_fetch:aHR0cDovL2Nsb3VkaW5hcnkuY29tL2ltYWdlcy9vbGRfbG9nby5wbmc/sample_url_image.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end