import re
regex = re.compile(r"<(\w+\:\w+(?:\.\d+|\d+(?:-\d+)+)?)>", flags=re.MULTILINE)
test_str = ("<staticText:HelloWorld>_<xmlNode:Node.03>_<date:2011-12-12>_<time:23-59-11-222>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")