import re
regex = re.compile(r"^(0|[1-9]+[0-9]*) (@[^@]+@ |)([A-Za-z0-9_]+)( [^\n\r]*|)$", flags=re.MULTILINE)
test_str = ("0 @N1@ NOTE Lorem ipsum dolor sit amet\n"
"0 HEAD\n"
"1 SOUR FTM\n"
"2 VERS 22.2.6.950\n"
"1 DEST FTM\n"
"1 DATE 31 MAR 2017\n"
"1 CHAR UTF-8\n"
"3 _LINK http://www.facebook.com/1247584965\n"
"2 SOUR @S122@\n"
"3 PAGE Facebook update - David Hatch - 6/5/2013\n"
"3 _LINK http://www.facebook.com/1247584965\n\n\n"
"1 RESI\n"
"2 DATE BET 1935 AND 1993\n"
"2 PLAC San Francisco, California, USA\n"
"1 RESI\n"
"2 DATE 1994\n"
"2 PLAC San Francisco, California, USA\n"
"2 SOUR @S605@\n"
"3 DATA\n"
"4 TEXT Birth date: 20 Sep 1966 Birth place: Residence date: 1994 \n"
"5 CONC Residence place: San Francisco, CA\n"
"1 RESI 106 Oakcrest Rd\n"
"2 DATE 26 MAR 2017\n"
"2 PLAC San Anselmo, Marin, California, USA\n"
"1 FAMS @F500@\n"
"1 FAMC @F656@\n"
"0 @I923@ INDI\n"
"1 NAME Vincent /Crilley/\n"
"1 SEX M\n"
"1 FAMS @F254@\n"
"0 @I5899@ INDI\n"
"1 NAME Marjorie Edna /Footitt/\n"
"2 SOUR @S506@\n"
"2 SOUR @S176@\n"
"2 SOUR @S168@\n"
"2 SOUR @S624@\n"
"3 DATA\n"
"4 TEXT Residence date: Residence place: USA\n"
"2 SOUR @S115@\n"
"3 PAGE Year: 1940; Census Place: St Paul, Ramsey, Minnesota; Roll: T627_1996; \n"
"4 CONC Page: 11A; Enumeration District: 90-73.\n"
"3 DATA\n"
"4 _TEXT Birth date: abt 1918 Birth place: North Dakota Residence date: 1 \n"
"5 CONC Apr 1940 Residence place: St Paul, Ramsey, Minnesota, United States\n"
"2 SOUR @S607@\n"
"3 PAGE Year: 1920; Census Place: Carrington, Foster, North Dakota; Roll: \n"
"4 CONC T625_1334; Page: 13B; Enumeration District: 117; Image: .\n"
"3 DATA")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")