package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\bde\b`)
var str = `determinado de necessidade de comer é e de`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}