re = /https:\/\/pan\.baidu\.com\/s\/\w+$/m
str = 'https://pan.baidu.com/s/1pa7EApPNc8WbgGfQ4nJJJQ
https://pan.baidu.com/s/1hI5tdwvXj8nDTfglFI2QXA
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end