package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d*\.(?:[^0]|0+)[^0]`)
var str = `0.00820289933
0.00000025252
0.858282815215
0.075787842545
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}