$re = '/[ (](([0-9] )?[\w]+ [0-9]{1,2}:[0-9]{1,2})[;)]/m';
$str = 'Lorem ipsum dolor sit amet, sea persius nonumes habemus cu. Eam ferri dicta ex, sit no torquatos reprimique. Ea tota democritum has, mel libris audiam voluptaria cu. Ex usu facer voluptatibus, nam ut commune democritum. Ea nonumes (1 John 3:1) recteque sapientem eum. Cum soleat mandamus te, (Matthew 6:6) eos affert volutpat et.
Quo ei iracundia consectetuer. Vim salutatus abhorreant at, quo ea postea equidem intellegam. Duo dicit cotidieque id, debitis noluisse fabellas sit eu. Qui ne integre patrioque, minimum inciderint eos ex, aliquando (Deuteronomy 10:18; Psalm 10:14) tincidunt intellegat est at. Sumo assum et nec, usu graecis adversarium te, cu mea quis lorem. In qui utroque propriae, ex mandamus argumentum vis, pro vidisse ceteros atomorum ex. Et mentitum referrentur';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);