re = /{\ ?{\ ?(\d+)\ ?}\ ?}/m
str = '{{111}}
{ {111}}
{ { 111}}
{{ 111}}
{{111 } }
{{111} }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end