$re = '/\d+/';
$str = 'May21
James
Adi22
Hello
Girl90
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);