$re = '/(?:"[^"]*"|[^,"])+/m';
$str = 'Hello, "a man, who is not a man"!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);