re = /[^][(),\s][^][(),]*(?:\[[^][]*]|(\((?:[^()]++|(?1))*\)))?/m
str = 'Wheat Flour [Wheat Flour, Wheat Gluten, Calcium Carbonate, Iron, Niacin (B3), Thiamin (B1), Ascorbic Acid], Water, Yeast, Salt, Vegetable Oils (Palm, Rapeseed, oils (sunflower, rapeseed)), Soya Flour'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end