# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<time>.+?)\s+(?<logname>.+?)\s+(?<log>.+?)$"
test_str = ("2023-02-06T08:09:46+00:00 kubernetes.var.log.containers.app-test-app-test-space-fb5ffca1ec-0_cf-workloads_opi-05942675f9f0dd17039304733f228e7abd6ebdfd91609baf1a7afefaeb33ced8.log {\"stream\":\"stdout\",\"log\":\"Console output from test-node-app\",\"docker\":{\"container_id\":\"05942675f9f0dd17039304733f228e7abd6ebdfd91609baf1a7afefaeb33ced8\"},\"kubernetes\":{\"container_name\":\"opi\",\"namespace_name\":\"cf-workloads\",\"pod_name\":\"app-test-app-test-space-fb5ffca1ec-0\",\"pod_id\":\"f4f2592e-ed57-4375-aff7-40c7b214abe0\",\"host\":\"ap-joy-sidecar-5\",\"labels\":{\"controller-revision-hash\":\"app-test-app-test-space-fb5ffca1ec-5bb7dc5769\",\"cloudfoundry_org/app_guid\":\"8fc07280-506c-49b2-ab00-a97222fcf0a5\",\"cloudfoundry_org/guid\":\"8fc07280-506c-49b2-ab00-a97222fcf0a5\",\"cloudfoundry_org/org_guid\":\"fdf0a222-33a4-46fd-a7f9-7955b9ea862c\",\"cloudfoundry_org/org_name\":\"system\",\"cloudfoundry_org/process_type\":\"web\",\"cloudfoundry_org/source_type\":\"APP\",\"cloudfoundry_org/space_guid\":\"f1b70a4b-7581-4214-b128-2f1597f7789d\",\"cloudfoundry_org/space_name\":\"app-test-space\",\"cloudfoundry_org/version\":\"ebfde654-e73c-48da-b55b-42a37a6ba139\",\"security_istio_io/tlsMode\":\"istio\",\"service_istio_io/canonical-name\":\"app-test-app-test-space-fb5ffca1ec\",\"service_istio_io/canonical-revision\":\"latest\",\"statefulset_kubernetes_io/pod-name\":\"app-test-app-test-space-fb5ffca1ec-0\"}},\"app_id\":\"8fc07280-506c-49b2-ab00-a97222fcf0a5\",\"instance_id\":\"f4f2592e-ed57-4375-aff7-40c7b214abe0\",\"structured_data\":\"[tags@47450 source_type=\\\"APP/PROC/WEB\\\"]\"}\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.