re = /(?:\n+|\A)?
(?<code_all>
(?<code_start>
[ ]{0,3}
(?:
(?<with_backtick>[`]{3,})
|
(?<with_tilde>[~]{3,})
)
)
[ \t]*
(?(<with_tilde>)
(?:
(?:
(?:
(?<code_class>(?&_code_class))
(?:
[ \t]*
\{[[:blank:]\h]*(?<code_attr>(?&_code_attr))[[:blank:]\h]*\}
)?
)
|
(?:
\{[[:blank:]\h]*(?<code_attr>(?&_code_attr))[[:blank:]\h]*\}
)
)?
)
|
(?:
(?:
(?<code_class>(?&_code_class))
(?:
[ \t]*
\{[[:blank:]\h]*(?<code_attr>(?&_code_attr))[[:blank:]\h]*\}
)?
)
|
(?:
\{[[:blank:]\h]*(?<code_attr>(?&_code_attr))[[:blank:]\h]*\}
)
)
)
\n+
(?<code_content>.*?)
\n+
(?<!`)
\g{code_start}
(?!`)
[ \t]*
(?:\n|\Z)
)
(?<code_trailing_new_line>\n|\Z)
(?(DEFINE)
(?<_code_class> [\w\-\.]+)
(?<_code_attr> [^\}]+)
)/mx
str = '``` .html
<ul>
<li>Code block first in file</li>
<li>doesn\'t work under some circumstances</li>
</ul>
```
`````` .html {#codeid}
</div>
``````
~~~ .html
<ul>
<li>Code block first in file</li>
<li>doesn\'t work under some circumstances</li>
</ul>
~~~
~~~
<div>
~~~
~~~
<div>
~~~
~~~
<div>~~~</div>
~~~
~~~
<p>```
```
<p>```
~~~
~~~
Some text
Indented code block sample code
~~~
~~~~
In code block
~~~
Still in code block
~~~~~
Still in code block
~~~~
~~~~~ .html {#codeid}
</div>
~~~~~
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end