$re = '/(?<=the color is )(?:red|green|blue)|(?:red|green|blue)(?= is the color)/m';
$str = 'the color is red
red is the color
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);