# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"GTM-[A-Z0-9]+"
test_str = ("<script>(function(a,s,y,n,c,h,i,d,e){s.className+=' '+y;h.start=1*new Date;\n"
" h.end=i=function(){s.className=s.className.replace(RegExp(' ?'+y),'')};\n"
" (a[n]=a[n]||[]).hide=h;setTimeout(function(){i();h.end=null},c);h.timeout=c;\n"
" })(window,document.documentElement,'async-hide','dataLayer',4000,\n"
" {'GTM-Z2GFZPK':true});</script>\n\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.