re = /(.*?)(?:\s(thisisoptional))?\s(.*)/m
str = 'Firstpartstring secondpartstring'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end