$re = '/(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)/m';
$str = 'vxw-dvs-9-virtualwire-9-sid-20008-10.28.214.0/23-BU-08
vxw-dvs-9-virtualwire-2-sid-20001-10.28.200.0%2f23-BU-00%2f01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);