#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(Name=")([A-Za-z\s\x22_]+)(\s+Value="[A-Za-z0-9-:\s]+")([\/>\s]+)(.*)$"
Local $sString = "App_Data App="MOD" Name="Genre" Value="Series"/><App_Data App="MOD" " & @CRLF & _
"Name="Show_Type" Value="Series"/><App_Data App="MOD" Name="Billing_ID" " & @CRLF & _
"Value="10092"/><App_Data App="MOD" Name="Licensing_Window_Start" " & @CRLF & _
"Value="2019-05-07 00:00:00"/><App_Data App="MOD" " & @CRLF & _
"Name="Licensing_Window_End" Value="2019-05-13 23:59:59"/><App_Data " & @CRLF & _
"App="MOD" Name="Preview_Period" Value="0"/><App_Data App="MOD" " & @CRLF & _
"Name="Display_As_New" Value="4"/><App_Data App="MOD" " & @CRLF & _
"Name="Display_As_Last_Chance" Value="7"/><App_Data App="MOD" " & @CRLF & _
"Name="Provider_QA_Contact" Value="NBC Universal"/><App_Data App="MOD" " & @CRLF & _
"Name="Suggested_Price" Value="0.00"/><App_Data App="MOD" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")