$re = '/(PREFIX(?=(?<spaces>[\s\S]+SUFFIX))\k<spaces>)/m';
$str = 'PREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXSPREFIXS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);