const regex = /^(?:(?:40\d[0-5]|[1-3]\d{3}|[1-9]\d{2}|[1-9]\d|\d),){3}(?:40\d[0-5]|[1-3]\d{3}|[1-9]\d{2}|[1-9]\d|\d)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:40\\d[0-5]|[1-3]\\d{3}|[1-9]\\d{2}|[1-9]\\d|\\d),){3}(?:40\\d[0-5]|[1-3]\\d{3}|[1-9]\\d{2}|[1-9]\\d|\\d)$', 'gm')
const str = `1200,2500,6500,90
1200,2500,6500,90
1200,2500,4095,90
0,0,0,0
999,1,0,99
000,000,000,000
4095,4095,4095,4095
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}