$re = '/{{image:(https?:\/\/[^\/]+)\/file\/d\/(.+?)}}/m';
$str = 'Some more text here
{{image:https://drive.google.com/file/d/1jYbEcuN-EMNkc0ELeVLveNJiaiuQt4XK/view?usp=sharing}}
Some text here
{{image:https://drive.google.com/file/d/2jYbEcuN-EMNkc0ELeVLveNJiaiuQt4XK/view?usp=sharing}}
Some more text here';
$subst = "<img src=\"$1/uc?export=download&id=$2\" />";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;