$re = '/(?<=^|(?:&&|\|\|) )(.+?) (contains) (.+?)(?= (?:&&|\|\|)|$)/m';
$str = '\'oil & blah\'blah\' contains \'oil&blah\'blah\' && \'oil & blah\'blah\' contains \'oil blah\'s\' || \'oil & blah\'blah\' contains \'oil blah\'s\' ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);