using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([2-9](?!11)[0-9]{2})";
string input = @"These would be valid area codes: 414, 608, 920, 319, 715
These would NOT be valid: 023, 123, 411, 611, 811, 911";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}